Category Archives: Exchange 2007

Random connection drops HyperV Proliant Gen8 server

We have an Exchange environment on an HP Proliant DL380p Gen8.  The VM’s came from old physical servers that were relocated to another site, ever since they were virtualized and put onto new hardware, there have been random network issues.  We could ping between all Exchange servers one minute, next minute, cant ping anything.

Found an article on Microsoft site about a bug in Broadcom Chipset with HyperV and Server 2012 R2.  Looked up the HP FlexLOM card, and sure enough, it uses BCM5719 chipset, one of the affected chipsets.  Also the driver we are using is 16.4 and the issue was resolved in 16.8.

https://support.microsoft.com/en-us/kb/2986895

https://www.broadcom.com/docs/features/netxtreme_ethernet_hp_datasheet.pdf

HP-FlexLOM-Broadcom

Exchange 2007 Mailbox Server VM bluescreen

Had an issue over the weekend, one of our mailbox servers kept bluescreening.  This particular VM has the C: and D: on  storage iSCSI SAN.

Tried running checkdisk on C: and it bluescreened as well.  HyperV manager shows the error “Cannot connect to virtual machine configuration storage”

The D: drive is showing uninitialized in disk management, and gives an error when trying to initialize.

Started getting “Windows – Delayed Write Failed” messages.  Compression is not turned on on the HyperV servers local storage.

The iSCSI connections are provided by HP Lefthand SAN, 2 node cluster.  One of the SAN nodes went down yesterday.

HP Lefthand Support Phone Number
1-800-633-3600
shortcut –
Lefthand Solutions

putty into SAN node : port 16022

2 Lefthand SAN nodes
Each has a single 100mbit link….
When we brought SAN2 back online state, issue was resolved
My assumption is that the SAN couldn’t replicate fast enough with the load they have with Exchange on them, plus replicate the changes to the other SAN node, so they were out of sync when the 1 SAN node went down thus causing issues.

mbx3-8

mbx3 mbx3-2 mbx3-4 mbx3-5 mbx3-6 mbx3-7

mbx3-8

Manually Remove Symantec Mail Security for Exchange w/ Script

Removing Symantec Mail Security for Microsoft Exchange 6.5 (SMSMSE) for Microsoft Exchange 2010/2007 after Add or Remove Programs does not work
http://www.symantec.com/docs/TECH123582

Manual removal script for Symantec Mail Security for Exchange (SMSMSE) for all versions
http://www.symantec.com/docs/TECH214662

SMSMSE_Remover
removeSMSMSEmanual
manualSMSMSEscript